adallak

Lifetime Supporter
  • Content Count

    4,420
  • Joined

  • Last visited

  • Days Won

    7

Everything posted by adallak

  1. adallak

    TPS and ICM Question

    It could be rather wiring/connector issue than the TPS itself. You can test TPS with a $10 mutimeter for smooth operation. Just watch Ohms change while moving the lever of the TPS by hand.
  2. I recall my 4.9 having a very big crack on exhaust manifold right behind radiator. Now, I think it could be the reason for rough idle. But I never had a poor fuel economy. I think I might have an exhaust leak (invisible crack, bad gasket, etc.) which affects fuel economy so dramatically. I can go ahead and replace the passenger side exhaust manifold, gaskets, etc. But, even replacing oxygen sensors was not a fun work at all on this old girl, that's what makes me a bit reluctant...
  3. Yes I have replaced (perfectly good) plugs. And I check them often. They look good. Spark wires are new as well.
  4. Yes, cracked exhaust manifold is a possibility, but you will not know until you actually take it off... Another PITA job, just like removing oxygen sensors was. And chances are it will do nothing ,just like replacing oxygen sensors did.
  5. Thank you, Mike. Sure, two heads are better than one, especially when the second head is yours! I sent you a message.
  6. Thank you , Mike. I sent you a message. I know you will not let me sit and wait till things get better by themselves! LOL
  7. Yes, Mike... I am sure I have covered almost everything... well, some day the cause will expose itself, I hope so anyway. Thanks for trying to help me!
  8. Funny, the reply in that thread comes from me (HUF). I do not think I have any leaky injectors, otherwise the fuel pressure would not hold for some 30 minutes when I prime the system. Right? No black smoke, no fuel smell in exhaust either.
  9. Mike, ALL the subjects you brought up were addressed except for exhaust restriction. Most of replaced parts are ACDelco. As I said, this car never had a code. Climate control shows any trouble code if you know how to get them, so I check everything now and then. No check engine light ever. I also know that a sensor can be bad and it will take a while to show a code, so I have replaced a lot of things "just in case". I have the FSM, of course. The vacuum is around 20" Hg depending on a location. It is a bit low, but that's all I have got. Optispark is vented and it works perfectly. Coil, wires, plugs are new and fine. Fuel trims would be probably helpful, but I am tired spending more $$$ on this old girl. I am trying to find a success story from someone fixing the problem just like this thread shows.
  10. LT1 takes regular. No, it is OBD 1. Unfortunately, there are so many things , which could affect fuel economy (or intermittent lack of power) and finding them is a PITA if you do not have proper diagnostics tools. I have heard too many stories how people would take the car to a dealer and after spending $$$$$$ they would just sell the car. I do not want o go that rout.
  11. No power-train related codes whatsoever and I never had one... There were always driveabilty issues such as sudden lack of power, hesitation, etc, but fuel economy was decent for many years. I have noticed dramatic drop two years ago. Again, I have replaced every part , which could be responsible. Just wasted money and time, I guess. 10 MPG around the town is just way too much. or should I say too less.
  12. Mike, I just did what you suggested. No fuel coming from the nipple. I am wondering what revving does to FPR if the vacuum line is taken off. There are FPR tests in the manual suggesting kinking return fuel line, etc, but I am a bit reluctant touching 23 years old hoses. Something tells me the FPR is fine. When I compare this LT1 with 123,000 miles to 4.9 with 175,000 in my 1991 Seville, this engine is so much cleaner and nicer, yet I never experienced lack of power, driveability problems, and terrible fuel economy with my Seville. This engine must have been tuned so that it is just too sensitive to possible exhaust, vacuum leaks, ignition, etc.
  13. I have connected a transparent PVC tube to the FPR and sucked the air providing around the same 20"Hg vacuum. There was vapor and there was no gasoline in the tube whatsoever. I think nothing is wrong with FPR. No symptoms of a bad FPR either.
  14. Rejuvenating an old thread. For the last two years, the fuel economy of my 1995 Fleetwood with 123,000 miles on the clock has been 10 MPG around the town. It is 17-22 MPG on a long highway trip. Unfortunately, 90% of my driving is around the town. I have done all the usual checks, which has been pretty much throwing parts at the problem. Still there. New O2 sensors, new exhaust manifold bolts, fuel filter, fuel pump, FPR is fine, injectors are not leaking, fuel pressure within specs, no visible vacuum leaks. I do smell exhaust under the hood but cannot find it. MAF is clean, IAT sensor shows 3.62K at +72F, engine coolant sensor is fine, no powertrain-related codes. EGR valve is new. Ignition is fine, no misses. This is super frustrating and costly. There are some driveability issues (lack of power now and then), but this car had them since the day one and they are not really fuel mileage -related. Transmission lock-up is fine, brakes are fine, tire pressure is fine. It is OBD1 and diagnostics tools are expensive and I am not sure they would help either. Just venting out my frustration and the pain at the pump! Took off the vacuum line and there IS a very, very faint smell of gas. No gas in the line or dripping from nipple of FPR. I just cannot see how that amount of gas vapor could mess things up. Obviously, there is no fuel loss through that vacuum line at all.
  15. adallak

    5% discount code for RockAuto.com

    6123292254921426
  16. adallak

    5% discount code for RockAuto.com

    7643210568220094 Expires on May 31, 2018
  17. adallak

    Guys, I need your help! PLEASE!

    I am also glad he changed the fuel filter .... 12 YEARS AGO!
  18. adallak

    Air Ride sagging

    Why not install passive air shocks? They are about $60 and come with all necessary tubings and fittings.
  19. adallak

    R instead of N...

    Things happened so fast and unexpectedly that I did not realize at the moment what was going on. There were was no jerking, hard drop in speed, violent shaking or noise. I made probably 100-200 yards before I have stopped. I only realized the engine was not running when I could not turn the steering wheel easily. The gear selector is on the steering column and it is a bit hard to see what gear you are in behind the steering wheel. Yes, it was cranking but not firing up.
  20. adallak

    R instead of N...

    This is so embarrassing... I was driving my 1995 Fleetwood down a hill at around 40 MPH. Wanted to put it in N and instead put it in R... Almost instantly put it back in N, then in D. I realized the engine has stalled only when I lost power steering. Stopped the vehicle and tried to start it to no avail. In about 15 minutes tried again and after several attempts it finally started and drove as if nothing happened! THere is a little noise when I shift from R -N- D or D-N-R (brakes applied). Do you think I can get away with this? I will NEVER touch the gear selector again while I am driving. Never.
  21. This home-made tool will help you to adjust the ISC motor plunger.
  22. adallak

    Fuel pump access door

    "Why did it take you 13 years to reply? " I have been waiting for GM to change!
  23. adallak

    Fuel pump access door

    Ranger, Unfortunately, not just cars but also almost anything can be poorly designed/conceived. Sometimes you take a shower and wonder if teh guy who designed the shower head EVER actually used it!! The same may apply to toilets, faucets, computers, you name it. People also have that unhealthy itch to modernize good old stuff (and make it unbearable). As for GM, the most annoying thing is that they often know about problems and do nothing about it.