Jump to content

LaDukeDeVille

Registered
  • Posts

    1
  • Joined

  • Last visited

About LaDukeDeVille

  • Birthday 06/20/1981

Previous Fields

  • Car Model and Year
    1997 Cadillac DeVille
  • Engine
    Northstar 4.6L V8 (LD8/L37)

Profile Information

  • Gender
    Male
  • Location
    Crow, Oregon
  • Interests
    Anything artistic
    My fiance and our 4 children (or Pack of children)
    Sports
    Cars
    Avid hunter
    Shoes

LaDukeDeVille's Achievements

  1. My Caddy folks I'm stressin a lil' here. While driving suddenly my transmission started slipping, so I thought. I found that it would engage a little bit in 1st or 2nd gear and would get going about 20mph and then start slipping again and would pull over shut it off all over again until I got home. After doing all the research and reading your guys's forms I replaced the speed sensor, Added fluid to my transmission because it was a little low got got it back into the cross hatched area on stick, Try resetting the whole computer by pulling ECM fuse while ign on waiting the time needed, plugged in my OBDII/EOBD scanner and no troubled codes, and have entered the on board diagnostics and still No change. But Im flying blind with the on board diags cuz my whole darn center cluster just went black on me one day and has been for bout 3 mos now. I have not checked shifter cable really but either way my Caddy wont move! Pleeease help.... Sorry for the very long message. Thanks LaDuke
×
×
  • Create New...