Jump to content

D-Rail

Registered
  • Posts

    6
  • Joined

  • Last visited

Everything posted by D-Rail

  1. That is exactly what they go to, gentlemen. Thank you very much for the help and peace of mind. The suspension was replaced with regular gas shocks. I appreciate the insight.
  2. Thanks a lot! I will have to take a look tonight. I do not have any service messages on the dash and the ride is smooth. I will check if the suspension has a replacement and if it is the same on other sides. I’ll let you know what I find!
  3. I figured out how to compress the photos so they fit in the thread. If someone know what these are please help! Thank you.
  4. My thought was the same about it having to do with power steering, but I have never seen anything like it. I’m more familiar with the 4.9L I had in my 1993 DeVille. Hopefully someone can help. Thanks! I look forward to the memories with this newer body style and the north star motor
  5. I just purchase a 1996 Sedan Deville from a tow yard. I had great luck a few years back buying a 1993 Deville from a tow yard and loved it. Found this one a purchased it a weekend or two ago. Been doing some mild tune ups such as oil change and plugs. Recently I was looking under the right front end of my bumper and found something wrapped in a plastic bag and zip ties to what appears to be the power steering cooling line. It looks like a sensor of some sort. I have never seen anything like it before and my original thought was it had to do with the transmission fluid because a tiny bit of pink fluid was in the tip. I have no clue where it goes but the cable isn’t more than a foot or two. Anyone know anything and can you help me ?? The engine and transmission run great and there are no engine lights on the dash. It has a threaded fitting on the end and two wires that go to a plug. I have photos but have no clue how to add them to the thread. I’ve never used a forum before.
×
×
  • Create New...