Jump to content

milansky

Registered
  • Posts

    58
  • Joined

  • Last visited

Everything posted by milansky

  1. You are killing me on this one. Temperature was as listed in the manual after a short warm up. PCM damaged? That would mess the whole car up not? Engine runs smooth and all other electronics are fine too or r u talking about pcm damage of transmission section in the pcm only? Will check the transmission fuse again. Regarding question above. Car was running absolutely fine never had any issues with transmission at all. No hard shifts whining noise or any of that. As I mentioned before Caddy is just above 76200 miles. But one day after traffic light stop transmission gave up on me.
  2. UPDATE: Both shift solenoids display required resistance 19 - 24 ohms (reading at 21,8 ohms). So we did one tricky thing. We clipped onto a wire (Engine side end) from 1-2 solenoid (light green) + 2-3 solenoid (yel/blk) + TCC solenoid (tan) + ground connection to manually command a shift. We made something like a switch board to which our wire clips were attached and took it for test drive. In "D" - solenoid A ON solenoid B OFF in first gear, in second gear A - OFF, B OFF, in third gear A OFF - B ON, in fourth gear A ON - B ON. Commanding through those switches did not change a thing so basically car was still in second with no change in rpms like of you had stick shift and changed your gear/speed by depressing clutch and upshifted by hand manually. So it is not electrical issue- shift solenoids or TCC. Does someone have a color diagram that would show how fluid travels within transmission when "D" is selected? There might be some kind of miniature blockage in valve body or something. Thanks
  3. OK, from what I see they require to measure it directly on solenoid itself by removing oil pan and not through the main electrical connector transmission end. It is a third time Im draining transmission.
  4. Anyone can explain what they mean by - measured across the terminals? In GM service manual it says: Shift solenoid resistance should measure 19 - 24 ohms. Shift solenoid current flow should not exceed 0,75 amps. The shift solenoid valve should energize at a voltage 7,5 volts or more (measured across the terminals). IMPORTANT: if both solenoids lose power only second gear shift will result = my situation but I need to clarify what they mean by across the terminals. We will check it through the main electrical connector end for transmission We shall also check the line pressure if it is within PSI as listed in the manual. Thx
  5. Dear Rockfangd. The reason for transmission overhaul was no shifting. Basically after engaging into D there was only speed up to 45 mph, high rpm and that's it - obviously P0741 code came up + service transmission light. So we figured that there might be also seal or gasket issues - low pressure within, valve body or sensors buried deep inside. All of that had been changed including filters, solenoids and wiring changed. Tranny looked very clean inside no metal residue from grinding or any of that SERIOUS stuff. Converter was also examined and has not shown any difficulties in turning or breakage of something inside. Still it is a 1996 Seville model with barely above 76000 miles on it so it is CANDY CAR well taken care of. As I mentioned above, ABS light and TRACTION CONTROL light had been on for a long time and never resulted in no shifting situation as. There are codes for rear wheel speed sensors, they will be checked again for resistance. Question stands, whether the ABS and TRACTION lights could have such serious role to play in transmission shifting. It seems like if transmission was in some kind of limp mode or something.
  6. No, there is no shift. R works fine. TC and ABS light had been on for ages never had any influence on tranny. Thx.
  7. Hi guys. This is quite interesting case since faulty transmission is out of question. Non shifting transmission on SEVILLE SLS 1996 (76 000 miles) has been dealt with by putting overhauled one in. Despite putting in overhauled transmission in car is still suffering with no shifting problems of being stuck in second gear. Codes appearing relate to traction control and ABS – TC 0027 and TC 0073. Obviously after test drive SERVICE TRANSMISSION comes on with 0741 code but this one is out of question since all seals, gaskets and solenoids were changed including valve body. The questions stands whether TRANCTION CONTROL and ABS module could have any role with transmission refusing to shift properly. Speed sensor on tranny functions properly, front wheel hubs with sensors changed for new ones. Any ideas? Milan
×
×
  • Create New...