Wht92STS

Registered
  • Content Count

    5
  • Joined

  • Last visited

About Wht92STS

  • Rank
    Observer (3-9 posts)

Profile Information

  • Gender
    Male

Previous Fields

  • Car Model and Year
    1999 Eldo ETC
  • Engine
    NORTHSTAR 4.6L V8 VVT (LH2)
  1. I've been told the hub assembly on either or both wheels is going bad when those codes come on, or it could also be the sensors that connect to the hub.
  2. Thx for the reply Ranger. O'Reillys sells Timkin hub bearings, would it be safe to purchase those from them? I'd be leery of anything else. I usually deal with Advance, but I'm not familiar with Driveworks, they also have Moog which I hear are good products also.
  3. I have a 99 Eldo ETC I just purchased with 65,000 miles on it. It had been sitting for 2 1/2 years. Upon taking possession of the car, I noticed when I stop at a light, then take off, a grinding sound comes from the front wheels and the traction control and service stability system, and ABS light came on the info screen soon after. I doesn't happen all the time. I got under the car to check the sensor that goes into the hub assembly to see if it was loose or frayed on both sides, and they checked out. I then checked the codes and a C1225 LF and C1226 RF code appeared. My next question is can the hub assembly go bad from just sitting ?? How expensive and hard is this to replace and what brand bearings are the best to use? I've heard some brands are junk.
  4. 92 STS 4.9 V8 new battery, went to start it the other day, turns strong but won't start, had been starting right up, not out of gas but low fuel light on. It could be a fuel filter or pump. Don't want to pay big $$ to get it towed neither. Trying to find out what it could be to fix my self. Not familiar with Cadillacs, bought this car at a auction. It has almost 200K on it. Not trying to drop loads of $$ in it. Thx for the replies.