Jump to content

johnmoore

Registered
  • Posts

    4
  • Joined

  • Last visited

Previous Fields

  • Car Model and Year
    98 deville
  • Engine
    Northstar 4.6L V8 (LD8/L37)

johnmoore's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. well guys thanks for all your help everything worked itself out and car was running like new then on my way home yesterday the car started to overheat but it wasn't hot and the onboard computer went crazy. I got stopped and shut it off and had it towed to a local shop. Head Gasket blew I had it comfirmed by cadillac UGH......... got five quotes they all told me buy a new engine it would be cheaper except one guy who has three devilles and he told me he would do it for me for just the cost of parts. he just wanted something to do. Thank god for good neighbors. But what I didn't understand was how could it blow like that when I tested it 5 days ago and it was fine. 4500.00 is way too much to fix actually cadillac was cheaper than two quotes I got. go figure so im off to go buy another car damnit I didn't want a car payment.
  2. well guys thanks for all your help everything worked itself out and car was running like new then on my way home yesterday the car started to overheat but it wasn't hot and the onboard computer went crazy. I got stopped and shut it off and had it towed to a local shop. Head Gasket blew I had it comfirmed by cadillac UGH......... got five quotes they all told me buy a new engine it would be cheaper except one guy who has three devilles and he told me he would do it for me for just the cost of parts. he just wanted something to do. Thank god for good neighbors. But what I didn't understand was how could it blow like that when I tested it 5 days ago and it was fine. 4500.00 is way too much to fix actually cadillac was cheaper than two quotes I got. go figure so im off to go buy another car damnit I didn't want a car payment.
  3. I did locate the coolant temp sensor last evening thanks for the schematic. Tried turning the A/C on but the fans still didn't come on but We did find a relay next to main fuse block in engine that was corroded and the wires going into it were broken. according to diagram it is my inadvertant power supply relay?? The thing is I have had no problem from this car until now my interior lights and cig lighters quit working and then my fans and all this other stuff with the cooling system. I have been religious with my maintenance on this vehicle it just seems odd to have this many things go wrong at once.
  4. I have a problem with my cooling fans not coming on the interior indicator is stuck at 194 when themastat opens I have good flow, new water pump, new hoses, and just had head gasket checked Also tested relays they are good I was told the temp sensor was bad but I can't find it to replace it. sounds dumb but I am getting nowhere and I don't want to blow up my caddy
×
×
  • Create New...