Sign in to follow this  
K-SOLO

09 D'Ville D'Elegance dash lights bilnking...

Recommended Posts

Hey guys. Got a 09 D'Ville D'Elegance. While driving the dash accessory lights(radio,remote controls on steering wheel,window controls,dianostic buttons...etc)blinks "on&off" constantly. How can i remedy this "irritating" issue??? Thanks guys...

Share this post


Link to post
Share on other sites

Is this an 09 Deville or your 99 Deville?

If the 09 is a typo, there was a problem with a diode in the trunk pull down unit that would cause that exact problem when it went bad. That problem would happen when the vehicle was sitting still or driving. If your problem only happens when driving, I would suspect a loose or poor ground though.


THERE IS ALWAYS ENOUGH TIME TO DO THE JOB RIGHT - THERE IS NEVER ENOUGH TIME TO DO THE JOB AGAIN !!!

Share this post


Link to post
Share on other sites

If this is a 99 Deville

Pull the codes

It may have a bad pot dimmer (dimming potentiameter )

does it only happen at night?

Do you notice any issues with the cluster or the control lights on either side of it .

If the button lights work fine on the cluster then I would say it is likely a connection issue at a splice in the dash. I would 

have to look it up once I confirm if the year is a typo


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites
On ‎8‎/‎8‎/‎2017 at 10:45 PM, rockfangd said:

If this is a 99 Deville

Pull the codes

It may have a bad pot dimmer (dimming potentiameter )

does it only happen at night?

Do you notice any issues with the cluster or the control lights on either side of it .

If the button lights work fine on the cluster then I would say it is likely a connection issue at a splice in the dash. I would 

have to look it up once I confirm if the year is a typo.   Yes,this happens at night...or when the lights are on.

 

 

Share this post


Link to post
Share on other sites

Ok humor me here, pop the defroster grille up.

In the center you will find 2 sensors.

The one you will want to remove is the one that is like a lamp socket. It is a twist and pull to remove and install.

It will be a round blue disc on the top with a dot in the middle. Check that to see if it is covered in dust. If it is clean it lightly and see if it continues to occur, 

If it does I recommend  replacing it. If it does not then you are good..

I am assuming your outside lamps may be acting  up also but are harder to notice.

Recommend pulling codes also. IPC IIRC

 


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.