hjb981

Registered
  • Content count

    539
  • Joined

  • Last visited

  • Days Won

    1

hjb981 last won the day on May 3 2016

hjb981 had the most liked content!

About hjb981

  • Rank
    Old Timer (500+ posts)

Contact Methods

  • ICQ
    0

Profile Information

  • Gender
    Male
  • Location
    Uppsala, Sweden
  • Interests
    Cadillacs ;)
    Photography
    Hiking
    I also like fixing stuff in general

Previous Fields

  • Car Model and Year
    DeVille 1997
  • Engine
    Northstar 4.6L V8 (LD8/L37)

Recent Profile Visitors

5,903 profile views
  1. I definitely smells in the tank. It is particularly noticable how different it is when compared side-by-side to new coolant. I suppose it could be exhaust I am smelling - it smells pretty bad. I still think that I can smell a bit of gasoline (although not as noticable this time - it varies), but of course it is hard to tell for 100 % sure, since it is a mix of different smells.
  2. Yes, the misfire is often worse right after a cold start. Then it can feel like it runs on 7 cylinders for 10 seconds or so. When idling warm, there is usually one or two misfires per second, (as felt and heard at the tailpipes). I did connect an OBD II reader to the car over a year ago (maybe over two years, before the oil problem, when I only had the misfire and O2 sensor problems). It showed fuel trim values that were off a lot to the positive (more fuel, and uneven, i.e. large difference between left and right bank). But that has become secondary to the oil in coolant and loss of coolant situation. With the OBD II reader, I could see that there were a lot more misfires on one cylinder (don't remember which now, maybe 5), even though I have not seen the cylinder-specific misfire codes (only the general P0300) on the on-board diagnostics.
  3. Sorry that this is so long again, but I have at least tried to use a bullet point format (each paragraph is a bullet point, just without the bullet in front). I have a base DeVille and hence the VIN 9, 275 hp engine. I am 100 % sure that I have a new radiator, since I order one from Rockauto and changed it myself. I am 100 % sure that the engine oil circuit is not connected to the radiator since I changed the radiator myself and disconnected/connected all components myself. The ATF that came out of the cooling passage in the radiator when I disconnected the ATF cooler lines from the old radiator was clear and red, like new ATF. The spring-loaded pressure-holding part of the pressure cap moves freely. Coolant (with oil) has passed the pressure-holding part of the pressure cap, ending up in between the pressure-holding part and the outer part of the cap (and thus also going through the little overflow tube that connects to the filler neck of the reservoir). This is repeatable (reappears if I clean everything and later check again). Coolant gets used up while driving and I have to refill periodically (increasingly often). If I would let the coolant reservoir get empty and continue driving, the engine would overheat, but this has not happened since I have always topped up before that happened. There is no dripping of any sort when the car is parked (no coolant, no oil). When the coolant gets used up, the coolant reservoir gets filled with gas (air or combustion gases). I cleaned both the throttle body and idle control part a few years ago after the throttle would stick slightly open, with increased idle speed as the result (it solved the problem). The spark plug wires, ignition coils and spark plugs were replaced recently (my first attempt at fixing the misfires), with only original parts used. The thermostat is present and was functioning properly for many years. The change in engine temp behavior has come slowly and gradually. All codes: PCM P0300 current. Engine Misfire Detected. Illuminates MIL unless there are only very few, isolated misfire events. Flashes MIL if misfires are occurring at a sufficiently high rate to risk damaging the catalytic converter. Disables TCC* if misfiring continues. * My DeVille has a VCC rather than a regular TCC. PCM P1381 history. Misfire Detected No ABS/PCM Serial Data. Could indicate false P0300. PCM P1645 current. EVAP Solenoid Output Circuit. Illuminates MIL. PZM B0533 history. Fuel Level Sensor Shorted to Battery. RFA B2560 current. I cannot find a verified description, but it indicates that I should resynchronize my RKE fobs or change the RFA unit. I have seen a lot more of P0300 than P1381, which also appeared much later. I can also feel and hear the misfires while driving. While idling, the misfires can be felt and heard as puffs through the tail pipes. The MIL is on, and it has been blinking occasionally when accelerating. The TCC (or VCC) is disengaged, which I can hear (engine revs faster for a given steady speed), feel and see on the tachometer. If I reset the codes while driving, the TCC engages for a while until misfiring is detected and it is disengaged again. I do not think that a faulty EVAP should cause misfires, and P1645 started appearing long after P0300. For some reason, the O2 sensor codes that I have seen are not set now (there have been several before, but unfortunately I do not remember the code numbers now). I was about to replace the FPR and continue with other tune-up stuff just about the time when the oil in the coolant started appearing, but I did not want to continue with that when something much more serious was going on. Abbreviations used: ATF: Automatic Transmission Fluid EBTCM: Electronic Brake and Traction Control Module EVAP: Evaporative Emission FPR: Fuel Pressure Regulator MIL: Malfunction Indicator Lamp PCM: Powertrain Control Module PZM: Body Control Module – previously referred to as Platform Zone Module RFA: Remote Function Actuator RKE: Remote Keyless Entry TCC: Torque Converter Clutch VCC: Viscous Converter Clutch
  4. Aha, I did not know that the little cooler up front was for the power steering. Actually, the DeVille Concourse had the VIN 9 engine, different final drive ratio (3.79 instead of 3.11 if I remember correctly) and road sensing suspension (the one with magnetic particles in the dampers). It was after a quick drive in one of those that I decided to get a Northstar. :-) I have considered the ATF possibility thoroughly and ruled it out, considering the following: - Oil started appearing in the coolant 2.5 years ago. It has since continued to appear at a slowly increasing rate. - I always keep track of the different fluids and have kept a very close eye on them for the last 2.5 years. - The ATF has never shown any trace of milkiness or anything else. It continues to be clear red and looks the same as new ATF. - The level of the ATF has not changed at all in any direction ever, including the last 2.5 years (even though I have emptied oil from the coolant reservoir several times). - The radiator is the only possible pass-over point for coolant and ATF (right?). I replaced the radiator after it burst about 1.5 years ago. It did not alter the way in which oil appears in the coolant in any way. Oil kept appearing at the same rate after as before the radiator change. The old radiator had clear signs of overpressure (expanded coolant passages). - The oil in the coolant has never had a trace of the red ATF color. - The oil in the coolant looks and smells like engine oil (except for when it smells like gasoline, below). - Sometimes, especially when opening the coolant reservoir and smelling it immediately (when cold, of course), it smells like gasoline. The gasoline smell in the coolant is very distinct and unmistakable. If I leave the radiator cap off for a while, the gasoline smell lessens and it smells more like engine oil and coolant (gasoline is much more easily evaporated than oil and glycol). I have also smelled gasoline in the engine oil (by smelling in the oil filler hole (I have smelled the oil several times before and I have not smelled that much of gasoline in it)). Under normal conditions, some gasoline in the oil is normal from blowby right after a cold start, but pretty quickly the oil heats up enough to evaporate it while the engine achieves more complete combustion and thus prevents further build-up of gasoline in the oil. This may be so little that it would not cause the oil to smell – I do not know. If the engine is running rich and also misfiring, accumulating gasoline in the oil could be expected (even if it also gets evaporated via the PCV and burned in the engine). If combustions gasses pass through to the coolant, I could see how gasoline could get in the coolant if both rich running and misfiring are present. The idle speed does not fluctuate at any time when the engine is idling by itself. The only time when the engine speed behaves strangely is when coasting in third gear. Not in forth, second or first gear. Not when idling in neutral or park. I cannot see how a sticking idle speed motor could explain why the engine should drop so much when the engine is being turned by the cars momentum (although it could explain why the PCM is not able to recover the idle speed as it should, i.e. the occasional drop to 400 rmp). It also seems very odd that it would not happen in any other gear than third (fast coasting in forth gear gives the same engine speeds, but never any drops), if it was not caused by the transmission. It is a good idea to actually test the coolant for combustion gasses. I have not done that. I do not have the codes right now, but they are related to the rich running (the O2 sensors do not swing like they should) and misfiring (P0300). I will have a look and post them later, but they will unfortunately not help with the big problem (oil in coolant). To make things weirder: over the last year or so, the engine has started running cooler and cooler, and now only reaches around 180 degrees F (not the normal 196 degrees F, which it always reached before). I have felt the engine with my hand, and it does feel less hot than before. It also takes longer for the engine to warm up. An idea of mine is that exhaust gasses leak into the coolant very close to the thermostat, which has led to it opening immediately and keeping the coolant temperature in check. Now, the thermostat may have been damaged and perhaps does not close like it should or opens too quickly. This is not the cause of any of the other problems, since all of them appeared long before the change in engine temperature (although it would make gasoline evaporation from the oil slower). As always, thanks for the help and input!
  5. The engine normally idles at around 650 rpm, but when coasting with the engine doing 1000 rpm, the engine is being driven at a higher-than-idle speed by momentum of the car through the transmission. At some point, the fuel should even cut off completely (maybe around 1000 rpm, but that is just a guess). If the fuel is already cut off because the engine has reached the threshold speed for fuel cut-off when the accelerator pedal is not pressed, that could also explain why the engine speed dips below idle speed sometimes, although it is weird that the PCM does not catch it in time. Maybe the algorithm for re-enabling the fuel injectors is different if the PCM senses that the car is coasting in gear (and hence should have a very predictable engine speed. Since this rpm drop only happens when the engine is turned faster by the car's momentum, I cannot see how it has to do with the engine. I think it has to do with the fluid pressure in the transmission being the lowest when the engine is at low speeds and some clutch or band used for the third gear being a bit weak. There are no transmission codes and the transmission certainly does not slip in "the normal way" (i.e. under load). There is no coolant in the transmission fluid, and the level is neither too low nor to high. If it was a bad solenoid the transmission should act up also under load, I suppose. A "normal person" would not notice the transmission thing, since it does not affect driveability in any noticeable way. I can hear the drop in engine speed because I am more attuned to how the engine should sound (even though you can barely hear it when the car i rolling and no throttle is applied) and obviously see it if I put on the rpm readout on the DIC. Anyways, there is no way that I would R&R the engine without also doing the transmission and viscous converter clutch. Too much of the cost lies in the R&R, and the engine and transmission come out together. And yes, there may be several problems with the engine. Tune-up related stuff, leaky injectors, fuel pressure regulator etc are additional possibilities. Although I did not say it outright, you are right that I also have high hydrocarbon values - although a leaky injector or fuel pressure regulator would not explain why hydrocarbons (gasoline) also would end up in the coolant. I have been trying to figure this out for the last couple of years, including some forum discussions. The problem has just gotten worse to the point that something needs to be done. Unfortunately I really cannot see how this can be solved in any other way than taking out the power train. The oil and gasoline in the coolant is a bad sign.
  6. Thanks for all the encouragement :-). I bought this car in 2004 at around 85k in California. After driving it there for a couple of years, I shipped my rust-free California car to Sweden when I moved back. The first thing I did was a complete anti-corrosion treatment: corrosion protection inside of the under-body beams, inside of the doors, hood, trunk lid and then a complete covering of the outside of all the under-body parts. Although there is some small rust spots on one back door and some more rust on the very lower parts of the doors on one side of the car, the structural components should be fine. The rust on the door is just in the sheet metal and should be easy to fix. So the car is fine, and I am keeping it. The question is more what I will do and when. The issue about oil in the coolant tank started a year and a half ago, and I actually drove about 40000 miles (I drove more than ever before in the last two years) after that started happening. Not ideal, but I never figured out exactly what was going on. There are pictures in this thread from back then: http://caddyinfo.ipbhost.com/index.php?showtopic=42997&hl=. One of the spark plugs have accumulated deposits since at least maybe six years - I always thought that was from oil leaking past a valve - and I mitigated the problem by changing that plug about once per year. The car does not have an oil cooler connected to the radiator (there is a small oil cooler in front of the radiator), but the transmission gets cooled by the radiator. A few years back, the radiator burst and I replaced it (hence I am very sure about the cooler lines) - something that could also come from a broken HG. The coolant system retains some pressure even when completely cold (and I have opened the radiator cap many times before the problem arose, so I am positive that what I see now is not normal behavior). There is some kind of smell in the coolant that may or may not be exhaust, but I have also smelled gasoline in it on several occasions, and that smell was very distinct and unmistakable. I guess the gasoline in the coolant comes from the overly rich fuel mixture (confirmed by the carbon monoxide value) bringing fuel to the coolant through some leak in a HG or elsewhere. It could also come from the misfire events. The transmission does not slip under load. It only happens in third gear when coasting, say at 20-40 mph. If the RPM is held at for example 1000 rpm by the speed of the car, it could then suddenly drop to 600 or even 400 rpm for a second. It does not happen when the car idles. I think I had a previous thread on this, but I cannot find it at the moment. BodybyFisher: thanks a lot for the offer to help! Do you know if it was possible to get that engine with some kind of warranty that was valid in Europe?
  7. Hi - it has been a while. I have had very little time to think about car stuff lately - even Cadillac stuff. I got married, defended my PhD, got a job, bought a house (I finally have a garage ), and very recently became a father. I still have the '97 DeVille, but it is now in need of some major renovations. There is oil going into the coolant (luckily not the other way around), misfiring, increased fuel consumption, high carbon monoxide levels in the exhaust, coolant consumption and so on. I am guessing a blown head gasket - certainly not something "less bad" - either way the engine will have to come out of the car and be swapped or completely remanufactured. The car has 200000 miles on the odometer and the transaxle has shown some signs of aging, namely sporadically dropping and rising engine RPM:s when coasting in 3:rd gear (as if the transmission slipped, although only when coasting). Given the mileage and cost of R&R:ing the powertrain, I would change or have the transmission remanufactured as well if I did the engine, even if it was not showing any signs of strange behavior. At the moment, the car sits in my garage and I have not actively started planning for repairs. Although it would be way more complicated than anything I have ever done on the car before, I would still have liked to do the work myself, but there is simply no way I can see that happening in the foreseeable future since I will not have the time. I do not want a ten-year dismounted car project... Given that I live in Sweden, my options for remanufactured Northstar engines and transmissions are far more limited than for those of you that live in North America. I still do not know exactly what options are available. At least there is a shop that works on these cars in my area that I have used over the years for other things. Any thoughts, recommendations or ideas? /Jonas
  8. 96 Deville Headlights

    Chiming in a little late, but I hope I have a few worthwhile considerations. The headlights in question (as all halogen headlights) are designed to work with a very small, omnidirectional light source: the filament of the halogen bulb. The reflector and lens are designed to project the correct light pattern from that light source. An LED replacement "bulb" consists of several LED:s mounted to emit light in about the same directions as a filament would have, but since each such little LED is a light source and emits light in other directions than those along lines from where the filament of a halogen bulb would have been, the light pattern will be altered. There are also light rays missing that would have been there in between the individual LED:s, which also alters the light pattern. The smaller the headlight and the larger the LED "bulb", the larger the effects on the light pattern. How big a problem this is in practice I do not know, because I have never tried a replacement LED "bulb". I doubt that any of them are legal replacements for halogen bulbs. For lights that are not intended to project a very specific beam pattern, such as tail light or side markers, this would be much less of an issue. Of course if you drive in snowy weather, the lower amount of heat produced by the LED:s would result in less snow-melting ability (turbulence behind the car quickly results in the rear end being covered in snow when you drive on snow). This also goes for the head lights. In certain conditions, the whole front end can get covered in an ice slush, with the exception being the part of the headlights where light exits. I have had this happen to the point where it was impossible to use the high beam (since it got iced up when I was running on low beam). With LED:s, it would probably have iced up completely. Of course ice and snow is of no concern to the OP in Florida... An HID bulb also has a very small light source: the electric arc inside of it. This arc is, however, not identical to a filament, and there are also color variations within the arc. Unless they have good filters, they may emit to much UV radiation that could damage the reflector and lens (which could also be a problem with a cheap halogen bulb if the manufacturer skipped the UV filter). I doubt that any HID replacement kits designed for mounting in halogen headlight housings are legal. The 9005/HB3 and 9006/HB4 bulbs are DOT approved, and it is not just the electrical power (wattage) of the lamp that is regulated in the standard, but also the total light flow. It is around 1000 lumens for a 9006/HB4 low beam bulb, and is allowed to vary about 10 % if memory serves me right. This means that there is no legal low beam bulb that outputs 30, 50 or 80 % more light than the standard bulb. When a manufacturer makes such claims, they make a bulb with a smaller filament that is positioned with great accuracy. A smaller light source means a more focused light pattern, which translates to higher light intensities in the brightest parts of the light pattern and less stray light. In this way, it may be possible to increase the amount of light in the brightest spot by perhaps 30, 50 or 80 %, but the total light output of the bulb is always within the regulated output limits for any legal bulb. A "+50" bulb may still be a good idea, but do not do not be fooled and think that it actually produces 50 % more light - what it does it that it aims the light more precisely by better filament design. I would not be surprised if the reference lamp used in such marketing is the worst possible lamp within the limits of the standard, but I do not know that. For 9005/HB3 and 9006/HB4 it is possible to use HIR1/9011 and HIR2/9012 after trimming one of the plastic tabs in the fastener. This is easy to do and outlined here among other places: http://store.candlepower.com/mohirbuba.html. Always wear safety goggles when working with halogen bulbs - unlike regular incandescent light bulbs, halogens are pressurized and could burst. Never touch the glass of a halogen, as it could result in later cracking or grease being evaporated onto the reflector. 9012 is a DOT approved low beam standard used in some cars with projector lenses, e.g. Dodge Viper (the lamps in such cars look like HID projector lenses, but are powered by halogen bulbs). These bulbs have exactly the same filament placements as 9006, and also the same fastener tabs, except that one is a bit wider (which is possible to change by trimming it). They do, however, lack the black top, so the low beam must have a protective metal cup that prevents light from going directly from the lamp and out of the housing, without first being reflected by the reflector. Otherwise they will cause unacceptable levels of glare. The output is over 1800 lumens for 9012 low beam bulbs, so they output about 80 % more light than 9006 lamps - for real. I have seen this myself and it is very noticeable. Since the power (wattage) is the same, 9012 bulbs will not produce more heat than 9006 bulbs and therefore not damage the housings. The rated lifetime is also not worse for 9012 compared to 9006. The higher light output is achieved by better lamp design. It is not legal to use a 9012 bulb in a housing designed for 9006 bulbs in traffic, but in my opinion it is a much better option than the also not legal LED or HID conversions that are available. On a 1997 DeVille (different lamp housings compared to a 1996), the low beam does have a metal cup, but the metal cup has little slits (openings) in it. Those small openings do not cause a glare problem in my eyes, and I have not seen others flash their lights (as some would if they were annoyed by glare) from the use of 9012 low beam bulbs. HID:s of today output somewhere in the order of 3000 lumens, and in my opinion it is safer for everyone with properly aimed 1800 lumen lights in cars with halogen lights compared to 1000 lumen lights, even if the former do not comply with regulations. This does not mean that I endorse or recommend anyone to do any illegal modifications. Edit: The OP's 1996 DeVille looks very nice. :-)
  9. Chassienummer på ram i nyare bilar

    Detta kanske inte är till jättemycket hjälp, men när jag 2006 importerade min DeVille -97 fick jag stansa in chassinumret i en tvärgående balk under bilens bakdel. Hittills har de inte kollat det på besiktningen, vilket jag är säker på eftersom det skulle vara nödvändigt att ta bort rostskyddet för att se numret.
  10. 5% discount code for RockAuto.com

    I just got my code: 2145475619379389, expires on June 15, 2014.
  11. Här finns det bra service!

    Kul att du har startat lite sidoverksamhet (om jag gissar rätt), synd bara att det är så långt till Skåne från Uppsala Jag och säkerligen många med mig uppskattar din insats på forumet; du har hjälpt många! Det var ett tag sedan jag var inne här också (mycket annat som tagit tid det senaste året). Lycka till med ekonomitentorna om det är några kvar /Jonas
  12. Golden Classics Ab ??

    Jag antar att det finns en anledning att du inte vill svara publikt, men om det finns delar av ditt svar som du känner dig bekväm med att dela öppet får du jättegärna lägga upp dem på forumet. Det kan ju finnas flera som har samma funderingar, eller så kanske det är någon som undrar och hittar detta vid senare tidpunkt. Jättebra att Ejje blev hjälpt, och om även fler kan bli hjälpta blir det ju ännu bättre
  13. 5% discount code for RockAuto.com

    I see the scarcity of codes as a good sign that our cars are holding up well I just placed an order, successfully using this code from a google search: 1989824917595230 I should get another code soon (from my own purchase) and will post it as well.
  14. I think that all of the '97-'99 DeVilles have dual climate control. I may be wrong on that one, but I am quite sure that both the base model and d'Elegance had column shifters; only the Concourse had a full center console with floor shifter. I am 100 % sure that there are base model DeVille's that combine a column shifter with dual climate control, since I have a base model '97 DeVille with both. The passenger side temperature is set with a knob that is located on the passenger side armrest, and it is not set in absolute temperature, but rather as an offset compared to the standard temperature that is set on the main climate control. In other words, even though the car has dual climate control, there is only one temperature that is set as a number and displayed on the dash. There are also no separate controls for the passenger temperature zone on the dash -- only on the passenger side door armrest. So it would be possible to have a look on the dash and think that the car does not have dual climate control, even though it does. The passenger side control knob can be set up to four notches (each notch representing one degree difference) lower or higher than the "standard" temperature, for a total of nine settings (including the middle setting -- no difference). It can be turned on and off by pushing the knob. When on, there is a little dial that lights up on the knob. The standard temperature (or turning the dual control off) often results in slightly warmer air on the passenger side, which makes sense since the driver is more active than the passenger(s) and therefore normally prefers a slightly cooler temperature. This only happens after the car is in good control of the temperature -- when starting on a hot day, it will of course blow full cold air, and when starting on a cold day, it will blow full hot air on both sides until the temperature approaches the set one. Either way, I think that it was quite doable to change the heater core even with dual climate control (see the link in my previous post). The hardest part when I did it was to remove the two hoses that go from the engine to the heater core. What makes it much easier on these cars compared to many other cars is that the heater core sits on the passenger side. If it would have been on the driver side or behind a full center console, it would have been much harder.
  15. Whether the heater core will turn out to be bad or not, I will just mention that I replaced mine a few years ago after it cracked. There is a step-by-step description of the procedure here: http://caddyinfo.ipbhost.com/index.php?showtopic=28646&p=167025 with a link to pictures a took during the job. My car is a '97 DeVille (and it has dual climate zones like a believe all DeVilles of that vintage had). Just a few words on coolant: like mentioned, 50-50 is ideal, and you should never decrease the amount of antifreeze (DexCool or whatever you use) below that for three reasons: the freezing point would go up, the boiling point would go down and the concentration of corrosion inhibitors would go down. If the concentration of antifreeze is increased, the boiling point will go up (also above 70%). The freezing point, however, will start to increase again when you increase the amount of antifreeze too much. The increased risk of coolant freezing and the lower heat capacity of antifreeze compared to water are the two reasons not to increase the antifreeze concentration above 70%. To absorb the same amount of heat, ethylene glycol (antifreeze) would increase its temperature more than water, meaning that the temperature difference of the coolant that entered the engine and the coolant that exited the engine would be greater. In other words, the cooling system would be less efficient. This reasoning holds as long as we assume that there is no boiling taking place in the hottest areas of the engine (if boiling does take place, it would be reduced by increasing the amount of ethylene glycol, which would increase the cooling system efficiency). Here is a good web page about ethylene glycol for cooling systems: http://www.engineeringtoolbox.com/ethylene-glycol-d_146.html