milansky

Registered
  • Content count

    48
  • Joined

  • Last visited

About milansky

  • Rank
    Participant (30+ posts)
  • Birthday 07/08/1977

Profile Information

  • Gender
    Male
  • Location
    Slovakia

Previous Fields

  • Car Model and Year
    Cadillac Seville SLS 1996
  • Engine
    NORTHSTAR 4.6L V8 VVT (LH2)

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. See if you can upload a photo #1 I sent you for others to see on the forum. The one with valve body in place a screen out of position.
  2. If u send me your email I will send u a picture of my previous transmission problem I was talking about. Thx
  3. Unfortunately I dont. I have basic obd scanner. Im based in europe so i will have to visit caddilac dealer about this. Too bad we got warm weather in 80's temp.so car reacts absolutely fine
  4. Yes that was checked. It's gotta be something that deals with temperature monitoring and mixing wrong air with fuel when it is called outside. As soon as engine warms up all goes back to normal. No oxygen sensor codes either. Im wondering whether faulty ECT sensor could be responsible for it.
  5. Hi. Slightly different topic. Have u ever assisted anyone on this forum with rough idle after engine start problem during cold weather? I get P 0101code awhile after start when engine shakes as crazy but it disappears as soon as engine warms up and rough idle settles. No other codes or vacuum leaks. No fuel related leaks. If IAC valve is responsible for proper air+fuel mixture during cold start with air temperatures around 32 up to 60F, could that be a problem?
  6. No clue about this one. I had no pressure related codes pointing at high pressure problems or something that forced the screen out
  7. No. Bracket intended for solenoids were not the case. There are small click-on pins that hold solenoids in place. It was all about that small screen and probably small original Oring on screen that simple popped out. We drilled very small and short hole (about 2milimiters) for miniature screw to hold it in. The screen im talking about.
  8. Here is update on 1996 Seville stuck in second gear: If your transmission is stuck in second gear make sure that O-ring on small screen/filter in between 2 shift solenoids in lower valve body holds that small screen in place all the way in. After transmission overhaul car was suffering in second gear only conditions over and over. No codes present. All solenoids replaced including screens and main filter. Will post a picture of what Im talking about after figuring out how to get a photo in here.
  9. Hi. Yes, that´s the screen I was talking about. Unfortunately I have new solenoids but without bracket. Purchased via rockauto.com. I replaced the lower valve body and reinstalled shift solenoids and small screen in between solenoids just like you pictured. All screen, filter are new also via rockauto.com. Regarding TConverter, tranny pan is clean no residue at all. After replacing lower valve body and putting refiltered AT fluid transmission worked fine, no whining, really smooth ride and shifting. Next day car ended up stuck in second gear ONLY with no codes at all. After removing pan I found that screen about quarter of inch popped out. I would post a photo for others to see but max.total size is 0,2MB. What? How did you manage upload photos on here? There is no way photo above is 0,2 MB. Thanks. By the way. Im getting a bracket to secure the lower valve body screen in position, cant trust that original Oring. After getting car running I will put update here.
  10. Solenoids and main plug readings are fine. The only thing we need to figure out is what is causing that small screen filter in between shift solenoid to pop out. O-ring on that filter seems strong enough to hold in place in lower valve body but something is forcing it out. It is second time we found it popped out about quarter of inch and it is after fully functioning transmission ended up being stuck in second gear. Is it possible for pressure switch located on lower valve body to force fluid under incorrect pressure to push out that small screen? This could be the reason for loss of fluid pressure in lower valve body.
  11. Friend of mine is great with car electricals + I have the same manual like the one shown. I have found quite interesting link below. That guy is talking about that small filter in between shift solenoids popped out which is also my case. https://www.justanswer.com/cadillac/99dsf-1994-cadillac-seville-sts-4t80e-transmission-it-s-stuck.html
  12. Main plug will be checked tmrw. Resistance of solenoids will be checked tommorow. They are brand new ones with new lower valve body just to make sure. All other solenoids were changed as well. The thing is that after changing lower valve body with fluid drained car worked fine smooth shifts as well. On next day again only second gear.