kaliphornia222

Registered
  • Content count

    11
  • Joined

  • Last visited

About kaliphornia222

  • Rank
    Reader (10+ posts)

Previous Fields

  • Car Model and Year
    eldorado 1996
  • Engine
    Northstar 4.6L V8 (LD8/L37)
  1. over heating

    ok ill check that tomorow ..
  2. over heating

    Hi ,, the radiator looked identical to the original one ,,, a friend of mine changed it but I picked it up at advance auto and compaired the two ,, as far as the AC ,,never had this problem of seeing peaks while not running ,,, coolant level is full,,could there be a relay at fault or sensor
  3. over heating

    HI, Prior to changing the radiator the temp gauge never went beyond 12oclock (just a line past 12 was normal),, since the installation of the new radiator the car runs fine until yu have to idle or move slowly in traffic,then the needle will creep up first past the 1st line past center then up to the 2nd line , once back to crusin speed the temp comes back down,, also if i drive the car for more the 10 min then stop turn it off run into the store ,,come back out and start drivin the gauge starts out high then comes back down within a few min of diving over 35mph without stopping ,,,it just seems like the fans arent turning on soon enough ,, after i checked the purge line I let the car idle for a while and it was getting close to the second line and still no fan ,,, I turned it off ,,,didnt want it to cause problems .....the fans do come on eventually ive seen them the last couple of times I checked ,,,
  4. over heating

    hi, ok i pulled the purge hose ,,coolant ran out,, started engine and a stream of coolant came out........so it looks like its not blocked ,,
  5. over heating

    Hi, the reason for changing the radiator is because it sprung a leak near the top .. this may have been my fault since there is not much room to do any work my ratchet hit it a few times while changing the alternator....soon after that i noticed a small leak ..
  6. over heating

    A radiator replacement means the fan(s) mounting bracket was removed. Are you absolutely certain the wire harness was not damaged or positioned incorrectly or the fan motors connectors were not damaged?? And the only way I can tell my fans are running is to use a flashlight and stick my head down there to be 100% sure the blades are spinning, Normal fan operation on my '98 model engine is like this: A/C OFF Fans to LOW speed (wired in series) when coolant temperature reaches approx. 223 F. Fans to HIGH speed (full voltage to both motors) if/when coolant temperature reaches approx. 234 F. Fans OFF when coolant temperature drops to approx. 212 F. The LOW to HIGH to OFF switching is determined by three relays in the underhood fuse/relay box. The PCM controls the relays based on coolant temperature information from the coolant temperature sensor. The fans are powered through a 50 A fuse in the RH MAXI fuse block. With an otherwise properly operating cooling system, you could leave the engine idling all day on the hottest day of the year and you might not "hear" the fans being cycled ON - OFF and you might not even see the temperature gauge move. Thanks for this info on the fans, the fans do turn on i can see them turning but maybe not on high ,, I will check the relays... and since the relays are based on the ect sensor could it be that it is fauly ,,, thanks
  7. over heating

    Thanks for the a/c info ,,, so now not realy sure what it could be ,, the radiator cap seems fine ,,ill get another one to make sure ,, the overflow hose is not clogged,,and i just looked at the location for the ect and looks very difficult to get to ,,, any way how can i tell when the fans are suppose to come on ....thanks
  8. over heating

    Thanks Ill check the water pump drive belt tensioner , what ive noticed is that it seems like while at cruisin speed the coolant is being air cooled and thats why the temp comes back down,, wonding if it has to do with the fan not turning on soon enough ,, also the ac needs to be charged ,, would that have anything to do with it,, lost the charge while changing the radiator ,,,thanks
  9. over heating

    thanks for that info ,,ive already covered the access hole on top of the heater box with muffler tape,, levels are good on coolant ,,no leak ,,already changed thermestate, could it be the ect sensor not telling the fans to come on sooner?
  10. Hi, i have a 96 Eldorado ,, recently changed the radiator. The temp gauge always stayed the same once operating temp was reached . Now while stopped in traffic the guage goes up to second mark passed center ,,, once the car is moving at crusing speed the temp gauge goes back to normal(one line above center line).. i can drive 300 miles no problems ,,only when im idling does the temp go up ,, ive notice that the fans do come on but maybe not soon enough, the heater core housing on the fire wall is crumbling from the heat ,,,,any suggestions thanks,,