SatchMax

2005 cadillac northstar misfire

4 posts in this topic

Wifes 2005 car with 29500 has misfire on start up.  Thought it was gas, new tank full, still misfires, but runs great after 8  to 10  miles of driving. 

shows 28  to 30  miles per gallon on gas. 

what could be causing this misfire on start up

SatchMax

Share this post


Link to post
Share on other sites

My guess is Fuel pressure regulator


Bruce

2016 Cadillac ATS-V gray/black; 2013 Cadillac ATS 2L Turbo Premium (Wife's)

Follow me on: Twitter Instagram Youtube

Share this post


Link to post
Share on other sites

Does the Service Engine Soon light ( SES ) come on?

My first thought is spark plugs or coil pack. Pull the plugs and check them for dry black sooty deposits which indicates rich mixture or weak spark.

spark-plug-lean-rich-optimal.jpg


THERE IS ALWAYS ENOUGH TIME TO DO THE JOB RIGHT - THERE IS NEVER ENOUGH TIME TO DO THE JOB AGAIN !!!

Share this post


Link to post
Share on other sites

I have a 02 Deville that sits for an extended period of time . It misfires when Started and sometimes it's real bad. I have a lifter, valve lash adjuster the bleeds down causing the mis and runs smooth as glass after a couple minutes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.