18 posts in this topic

Hey guys I have an 04 srx v8 northstar. I just purchased it with a known misfire #7. I through a set of filters and ngk plugs and coils at it and now I only have a soft skip at idle. It gives me cylI Der number 8. I changed the plug coil and injector to different cylinder and no change. Also did compression and that was good. I have 15inhg vac at idle and needle jumps a little with the skip. If I unplug number 8 it gets much worse of skip. Fuel pressure running is 60. I left gauge on for the day taped to windshield and one trip into store it had dropped down to 15 psi in 30min. But only that one time. I did intake gaskets also. When doing that I noticed a few different cylinders had new valve seats. Front of motor is dirty so I'm assuming awhile ago it broke chain and eat some valves. But last owner was great guy and he had it from 80k to 110k when I bought it and knows nothing of it. I had the car stall today when going from reverse to drive and it gave me a good misfire after p0300 and p0308 and also a p0019. Not sure where to go at this point.thanks in advance 

Share this post


Link to post
Share on other sites

Welcome; nice descriptive first post.

P0019  Conditions for setting the DTC’s are the ECM detects one of the following conditions for more than 4 seconds: 1) a camshaft is too advanced or retarded in relationship to the crankshaft, 2) a deviation in the relationship between a camshaft and the crankshaft.

Nice reference reading for Northstar: https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&cad=rja&uact=8&ved=0ahUKEwiq4u-gicHSAhVG54MKHX72CgYQFgggMAE&url=http%3A%2F%2Fwww.autonerdz.com%2Fyabbfiles%2FAttachments%2FGM_CAS.pdf&usg=AFQjCNHrzYmtqelf3JlZA17hzersKgIhUA&sig2=GYqryPRuqRwR9tZWN0bf0g

There was a trouble bulletin on the V6 engines referenced here but logic may be similar on V8:  Cause: This condition may be caused by stretched primary drive and both secondary drive timing chains. But usually you'd get more than one indicator.

 

 


Bruce

2016 Cadillac ATS-V gray/black; 2013 Cadillac ATS 2L Turbo Premium (Wife's)

Follow me on: Twitter Instagram Youtube

Share this post


Link to post
Share on other sites

Could also be a sticking cam actuator. But the fix would be the same -- new timing kit to replace chain, timing gears, etc. 

I see someone has a bunch on ebay at the moment http://www.ebay.com/itm/GM-Cadillac-Oldsmobile-4-0L-4-6L-DOHC-V8-Northstar-Timing-Chain-Water-Pump-Kit-/190889064341

s-l1600.jpg

But wait to hear others chime in; they may have diagnostic suggestions.

 


Bruce

2016 Cadillac ATS-V gray/black; 2013 Cadillac ATS 2L Turbo Premium (Wife's)

Follow me on: Twitter Instagram Youtube

Share this post


Link to post
Share on other sites

Vacuum is a little low. I would expect to see more like 17-18, but I'm only a little concerned about that. Pull #8 spark plug and make sure it has the proper plug gap. I've seen the plugs "change" gap during install, especially if they are dropped into the hole. Is the P0019 current or did it display as history? Is it still current or history? What was the compression reading on #8? Do a dry and a wet test on #8 and record both readings. Did you have ALL the plugs out when you did the compression test? Does #8 plug appear lean? Check #8 injector, switch the injector to another cylinder and see if it moves the misfire.


THERE IS ALWAYS ENOUGH TIME TO DO THE JOB RIGHT - THERE IS NEVER ENOUGH TIME TO DO THE JOB AGAIN !!!

Share this post


Link to post
Share on other sites

I have swapped coils injectors and plugs misfire still there. It is intermittant. And today it would all of a sudden show oil light come on and scan tool reads 5psi and will climb to 24 when I rev it. Hoping bad sensor. Is also started to stumble at idle and randomly stall. Fuel pressure still at 60psi. When stumbling it smoked out back as if over fueling yet no codes showing that. 

Share this post


Link to post
Share on other sites

If you have a stethoscope, check for lifter rattle at #8


THERE IS ALWAYS ENOUGH TIME TO DO THE JOB RIGHT - THERE IS NEVER ENOUGH TIME TO DO THE JOB AGAIN !!!

Share this post


Link to post
Share on other sites

No rattle. When I had intake off I noticed it had new valve seats installed but looked like it was awhile ago. I'm thinking maybe stuck cam actuator

Share this post


Link to post
Share on other sites

Could be, that IS at the end of the oil path. Or, @BodybyFisher had one that had a bad bore, it lost oil pressure also....

BodybyFisher likes this

THERE IS ALWAYS ENOUGH TIME TO DO THE JOB RIGHT - THERE IS NEVER ENOUGH TIME TO DO THE JOB AGAIN !!!

Share this post


Link to post
Share on other sites

In ordered a sensor just incase. Until car warms up its just a soft skip but smooth down rd

Share this post


Link to post
Share on other sites

I'm also averaging 9 miles a gallon 

Share this post


Link to post
Share on other sites

This is an 04 Northstar different than the 93-99, but......this is the end of the line in #7.  

If you carefully look at the path of oil flow in the NS, debris if there is any can be carried to the last lifter on the exhaust galley.  On my 97, debris seriously scored the last exhaust lifter bores in both banks causing the front bank exhaust lifter clearance in #8 to be about .0055, the allowable clearance is .001 to .003, this caused a misfire at idle that stopped as the oil pressure rose as rpm increased.  I have surmised that at idle when the oil pressure is about 10 psi at the adapter, the clearance was so large in that #8 lifter that it collapsed because oil leaked around the lifter due to the out of spec clearance.  On the 04, you have roller cams, I am not sure what could be damaged by debris in your #7, maybe the lifter oil feed hole became clogged with filings and it won't pump up.  

This is what caused the debris in my engine

20151119_180242_zpsa8b9ygge.jpg


Pre-1995 - DTC codes OBD1  >> http://z-cut.de/US/dtcobd1.html

1996 and newer - DTC codes OBD2 >> http://carprogrammer.com/Z28/PCM/OBD2/On-BoardDiagnosticTroubleCodes(OBD-II).mht

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Share this post


Link to post
Share on other sites

I was laying on the ground looking up when I saw this and my mouth dropped

108_2391B_zps31343eda.jpg


Pre-1995 - DTC codes OBD1  >> http://z-cut.de/US/dtcobd1.html

1996 and newer - DTC codes OBD2 >> http://carprogrammer.com/Z28/PCM/OBD2/On-BoardDiagnosticTroubleCodes(OBD-II).mht

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Share this post


Link to post
Share on other sites

You can take a sample of your oil and send it to Blackstone Labs for oil analysis to determine if you have a high level of metallic material in suspension and what kind of metal it is.   If you send your oil in, warm your engine up before taking a sample.

Blackstone

http://m.blackstone-labs.com/

 


Pre-1995 - DTC codes OBD1  >> http://z-cut.de/US/dtcobd1.html

1996 and newer - DTC codes OBD2 >> http://carprogrammer.com/Z28/PCM/OBD2/On-BoardDiagnosticTroubleCodes(OBD-II).mht

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Share this post


Link to post
Share on other sites

I ordered oil pressure sensor and I'm debating on weather to just pull front off engine and do a timing chain set and hope that's it.

Share this post


Link to post
Share on other sites

I'll do another compression tests tomorow and see if it's valve issue. The gauge does shake a little at idle and reved up 

Share this post


Link to post
Share on other sites

Inspect all parts, if a guide lost its wearing surface.  It certainly sounds like you may have a guide problem, do you hear noise by the front cover?

Did I miss something why do you need a new oil pressure switch?


Pre-1995 - DTC codes OBD1  >> http://z-cut.de/US/dtcobd1.html

1996 and newer - DTC codes OBD2 >> http://carprogrammer.com/Z28/PCM/OBD2/On-BoardDiagnosticTroubleCodes(OBD-II).mht

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Share this post


Link to post
Share on other sites

WOW, 9 MPG is terrible :excl::excl: Are you sure those are the only codes you are getting? My 98 Seville gets 26 MPG HWY and 20 MPG around town.


THERE IS ALWAYS ENOUGH TIME TO DO THE JOB RIGHT - THERE IS NEVER ENOUGH TIME TO DO THE JOB AGAIN !!!

Share this post


Link to post
Share on other sites

@BodybyFisher He had a low oil pressure warning.....


THERE IS ALWAYS ENOUGH TIME TO DO THE JOB RIGHT - THERE IS NEVER ENOUGH TIME TO DO THE JOB AGAIN !!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.