sethc1020

Put a new radio in my 08 CTS now it won't start

32 posts in this topic

Update.

So im about to pull.my hair out at this point.  Ended up buying a new radio from a place in ct that said they would program it with my vin info and it would come ready to go to just plug it in.  Well it came today hooked it up and guess what?  Screen says locked!!!!  Im so mad at the moment.  Emailed the place i got it from and they say there must be something wrong with my vehicle because it was a brand new radio and to send it back for a full refund.  Now i dont know what to do.  What else could be causing this???  Im starting to seriously  hate this car!!

Share this post


Link to post
Share on other sites

20 minutes ago, Logan said:

Curious....what was wrong with original 

It started randomly going cutting out and going black.  Sometimes it would come back on sometimes it wouldn't come back on for a few hours.  Eventually it went out and wouldnt  come back on. When it did none of my ac controls would work either.  Took ot to the dealership and was told my radio was no good.  The other 2 radios ive tried my ac controls work again but the radio still says locked.  Im not getting any other error codes or anything.

Edited by sethc1020

Share this post


Link to post
Share on other sites

I would see if the radio can be fixed. When the dealership told you the radio was no good were you given a specific reason? Was there a trouble code, such as a communication code or something that could be related?

Share this post


Link to post
Share on other sites

No code at all radio just went out and nothing on the screen plus lost control of the whole center console except for the flashers and traction control.   When i hooked up the other 2 radios screen says locked but everything else works again

Share this post


Link to post
Share on other sites

Here is a link to a website that fixes Cadillac OEM radios. Cadillac Bose Amplifier / Speaker and Stereo Repair 

Here is a link to same website's homepage: Factory Car Stereo Repair, Inc.

I suggest you call and/or submit a request for a quote to see if your radio is one that can be fixed. It may be something minor.  No power and glitching out may be nothing more than a defective switch.  You will never know unless you give it a try.

Share this post


Link to post
Share on other sites

By the way, maybe the problem is the amplifier.  Did you try removing positive and negative battery cables and touching them together to reset electronics?  This was one suggestion I read about radio problems that may or may not work. It seems to me that your best bet is to try to figure out what the problem is with the original radio.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.