69-er

Ill-Fitting Caliper Rebuild Kit

2 posts in this topic

I started to reassemble the rear calipers on an 83 Seville and noticed that the piston seals were a little too big. I thought the kit may have been defective, but I compared them to the ones I removed and they were the same size. Has anybody run into this before? On every caliper I've rebuilt in the past the seals fit the pistons exactly with no slop.

I was able to insert the seal into the groove with a little more difficulty than usual. The piston can also be inserted into the bore but it seems too tight. I'm concerned the piston won't retract enough from the rotor to float as its supposed to.

Thanks!

Larry

Share this post


Link to post
Share on other sites

You are referring to the o-ring and not the dust boot right? If so, as long as the o-ring is the same size as the one you removed and the piston goes into the bore, you should be fine. The rotor doesn't float - the caliper is what floats. When pressure is applied, the caliper will move slightly as to center itself.


Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.