Search the Community

Showing results for tags 'engine'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Cadillac Help and Discussion
    • General Cadillac Forums
    • Cadillac Grooming: Details on Detailing, Looking Good and Showing
    • Cadillac Builds and Project Cars
    • Cadillac Photography
    • Cadillac Master Craftsman Recognition Hall
  • Cadillac Clubs are Welcome on Caddyinfo.com
    • Cadillac Club Sweden
  • General Motors News
    • General Motors News
  • Cadillac Help and Discussion by Model
    • Cadillac CTS, STS 2005+, 04-09 SRX, CTS Sport Wagon (Sigma)
    • Cadillac V-Series Forum
    • Cadillac ATS
    • Cadillac XTS
    • Cadillac Deville, Eldorado, Seville, Fleetwood, Sixty Special
    • 2010+ Cadillac SRX, XT5, XT7, XT4, XT3
    • Cadillac Escalade, EXT, ESV Help and Discussion Forum
    • Cadillac Converj / Cadillac ELR
    • Cadillac XLR and XLR-V Help and Discussion Forum
    • Cadillac BLS Help and Discussion
    • Cadillac Companion Cars -- LaSalle, Buick, Chevrolet, GMC
    • CT6
  • Competitor Cars -- Cadillac Competitors
    • Competitors: BMW
    • Competitors: Porsche
    • Competitors: Mercedes
    • Competitors: Infiniti
    • Competitors: Others
  • Cadillac FAQ, How-To, Tips and Hints
    • Cadillac Owner Tips and Hints
    • Cadillac Links
    • Cadillac For Sale -- Private Parties or Supporting Vendors
    • CaddyInfo Forum Suggestions and Notes
    • CaddyInfo Polls
    • Green Technology, Future Power Sources, Fuels
  • Caddyinfo.com Supporting Vendors/Supporters/Subscribers Section
    • Crest Cadillac
    • Cardio-Doc on Wheels
    • Supporter's Cadillacs
    • CaddyInfo Supporter Section
    • B&B Automotive, LLC -- Northstar Repairs
  • New Members Section -- Introduce Yourself & Stay Awhile! Also, non-Cadillac related Topics
    • The 19th Hole Lounge & Member Introductions

Calendars

There are no results to display.


Found 5 results

  1. Hello folks I own a 1999 Cadillac Deville and I was told by my mechanic that I have a blown headgasket... We have tried using blue devil headgasket sealer which worked for about 1 day and then the overheating appeared again. I was quoted by my mechanic that the job to fix the engine would cost anywhere between 2500-5000 dollars depending on the severity of the damage. Coolant was replaced thermostat was replaced... unfortunately this did not fix the issue I rely on my Cadillac heavily for work and I need a inexpensive fix and fast one ASAP that will last me and not pillage my bank account so that I can continue working. if anyone has any advice on how and what I should do thanks...
  2. So I got a oil change on Friday then Saturday night drove my 98 DeVille you know just cruising. Sunday morning I hit the junkyard came home and got in my caddy and I was letting it warm up and it shut off by itself. Weird, now at this point I already knew my EOP SENSOR was bad but it's been bad for a while. It started making like a shutter noise from back of block almost where the spark plugs is but I hear it clearer from bottom of my block. More like a rattling some where in between. It wants to stall when I drove it to my mechanic. Any ideas in new on here. Thanks I'll try my best to answer some questions. That I know of my crankshaft positions were okay I did have them changed but it seems like they worked for a while then I would get the same codes for them. They are notorious for going out on these models.
  3. Hi - it has been a while. I have had very little time to think about car stuff lately - even Cadillac stuff. I got married, defended my PhD, got a job, bought a house (I finally have a garage ), and very recently became a father. I still have the '97 DeVille, but it is now in need of some major renovations. There is oil going into the coolant (luckily not the other way around), misfiring, increased fuel consumption, high carbon monoxide levels in the exhaust, coolant consumption and so on. I am guessing a blown head gasket - certainly not something "less bad" - either way the engine will have to come out of the car and be swapped or completely remanufactured. The car has 200000 miles on the odometer and the transaxle has shown some signs of aging, namely sporadically dropping and rising engine RPM:s when coasting in 3:rd gear (as if the transmission slipped, although only when coasting). Given the mileage and cost of R&R:ing the powertrain, I would change or have the transmission remanufactured as well if I did the engine, even if it was not showing any signs of strange behavior. At the moment, the car sits in my garage and I have not actively started planning for repairs. Although it would be way more complicated than anything I have ever done on the car before, I would still have liked to do the work myself, but there is simply no way I can see that happening in the foreseeable future since I will not have the time. I do not want a ten-year dismounted car project... Given that I live in Sweden, my options for remanufactured Northstar engines and transmissions are far more limited than for those of you that live in North America. I still do not know exactly what options are available. At least there is a shop that works on these cars in my area that I have used over the years for other things. Any thoughts, recommendations or ideas? /Jonas
  4. I just brought a '97 D'elegance yesterday for $1,000 in Maryland. It overheats almost immediately. Every time I drive it the temperature shoots up pretty fast around 244F in about 5-10 minutes or so. What did I get myself into? I think I got got. Oh well. What are some fixes? I dumped $135, for a battery, $240 for MDTags, $10 for tool kit to put in battery and tags, $ 368 for 1st and last months insurance. As well as the $1,000 for the car. I'm felling stubborn. I want to make it work. I refuse to just have wasted almost $2,000 in less than 24hrs!
  5. One day I went to start my car and it just wouldn't turn on, and the battery light was on and it sounded like a dead battery so i got a new one since it was almost time anyways. Shortly after doing so the same thing kept happening so i thought it was fuel injector or some type of problem with the fuses so I took it to the dealership and they said they couldn't find anything wrong with it. This problem however doesn't happen every time i start the car, in cold weather it happened a lot so i assumed the engine just needed to get warmed up so i would start it in neutral with the e brake on so i could rev the engine and get it going. things seemed to be getting better as the weather got warmer but it still happens every once in a while but usually starts after a few tries. The engine only has about 70,000 miles on it, and today when I went to start it the same thing had happened however unlike before as the "service engine system" would pop on and off randomly, the message "service charging system" popped up and followed by "battery not charging". This is the first time this message has popped up and I'm hoping it will help me solve the problem. does anyone have any idea of what it might be? Thanks in advance!