Search the Community

Showing results for tags '1997'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Cadillac Help and Discussion
    • General Cadillac Forums
    • Cadillac Grooming: Details on Detailing, Looking Good and Showing
    • Cadillac Builds and Project Cars
    • Cadillac Photography
    • Cadillac Master Craftsman Recognition Hall
  • Cadillac Clubs are Welcome on Caddyinfo.com
    • Cadillac Club Sweden
  • General Motors News
    • General Motors News
  • Cadillac Help and Discussion by Model
    • Cadillac CTS, STS 2005+, 04-09 SRX, CTS Sport Wagon (Sigma)
    • Cadillac V-Series Forum
    • Cadillac ATS
    • Cadillac XTS
    • Cadillac Deville, Eldorado, Seville, Fleetwood, Sixty Special
    • 2010+ Cadillac SRX, XT5, XT7, XT4, XT3
    • Cadillac Escalade, EXT, ESV Help and Discussion Forum
    • Cadillac Converj / Cadillac ELR
    • Cadillac XLR and XLR-V Help and Discussion Forum
    • Cadillac BLS Help and Discussion
    • Cadillac Companion Cars -- LaSalle, Buick, Chevrolet, GMC
    • CT6
  • Competitor Cars -- Cadillac Competitors
    • Competitors: BMW
    • Competitors: Porsche
    • Competitors: Mercedes
    • Competitors: Infiniti
    • Competitors: Others
  • Cadillac FAQ, How-To, Tips and Hints
    • Cadillac Owner Tips and Hints
    • Cadillac Links
    • Cadillac For Sale -- Private Parties or Supporting Vendors
    • CaddyInfo Forum Suggestions and Notes
    • CaddyInfo Polls
    • Green Technology, Future Power Sources, Fuels
  • Caddyinfo.com Supporting Vendors/Supporters/Subscribers Section
    • Crest Cadillac
    • Cardio-Doc on Wheels
    • Supporter's Cadillacs
    • CaddyInfo Supporter Section
    • B&B Automotive, LLC -- Northstar Repairs
  • New Members Section -- Introduce Yourself & Stay Awhile! Also, non-Cadillac related Topics
    • The 19th Hole Lounge & Member Introductions

Calendars

There are no results to display.


Found 3 results

  1. I hope I am posting in the right spot. I have a 1997 Eldorado ETC, 108K miles. It had a crack in the radiator upper right side. I replaced the radiator and tstat, but, its still overheating after about 15 miles. I have flushed the block and new radiator, cooling fans work, pass over not plugged. I have run it with and with out tstat. I am at wits end. All I can come up with is the heater core (which shows on signs of leakage) It has also developed a good miss, I think I need to replace a couple coils, no biggie, unless it is related to this. Any help or advise is GREATLY appreciated.
  2. Hello, I bought a 1997 Cadillac Catera in May of this year. When I bought the car I had it serviced and all seemed well. Later I began to notice a burning smell coming from the car and smoke coming from under the hood. Took to a mechanic to have it diagnosed and he said it needed new valve cover gaskets to start with. Replaced those and cleaned the engine well. (When I changed the gaskets, the spark plug resevoirs were full of oil) Cleaned them out, put new plugs in, new gaskets, and all seemed well up until recently. It is smoking from the drivers side of the engine and the bottom left front of the engine is drenched in oil which I suspect could be either motor oil or power steering fluid. I plan on taking it to a mechanic, but I was just wondering if anyone has had any experience with this before and what could be some possible leak locations? Thanks and all comments and replies are welcome!
  3. Just bought a 97 Deville. Really great car. 42,000 miles, one owner. Clean history, car always serviced by Cadillac. Also have a couple of older Cadillacs. 76 Seville, 78 Eldorado and 87 Coupe Deville. Member of Cadillac Lasalle Club, but I think with the newer car, this might be the place for advice. This car is a different animal. Took me 10 minutes to get the air filter box apart. With the 70’s cars can do it in the dark with my eyes closed. The previous owners said that the car does not keep a charge. After a few days of standing the battery is dead. They tested the battery and alternator (so they say), and everything turned out fine. The lights seem to dim slightly when driving at night, not applying any throttle. Also when I apply the brakes I can see a SLIGHT dimming of the lights. Just a tad dimming, then the lights brighten again. The display reads above 13, up to 14 or so volts while accelerating. No codes. Even under idle the display reads around 13 volts. I just bought a new battery, and it does the same thing. I took the old battery in, and they said it looks fine, but only 26% charged. I drove around the whole weekend, probably 300 miles !!!! If the alternator is bad, would the display still read over 13 volts? Anything else it could be? The belt / and / or pulleys also seem to be squeaking. Just ordered a new belt and idler pulley. Belt actually looks fine. If still squeaking will replace tensioner too. What is the torque specs for the pulleys? (will get factory manual soon). I replaced the alternators on my other cars, easy as can be. Two bolts and thats it. With this one I really want to be sure its the alternator before I have to go in there. Dont even know where to start. On a side note. The Dex Cool looked great. Oil life was good, only thing is the air filter was FILTHY. !! Don’t know if the dealer ever replaced that air filter.