Quenton6

Registered
  • Content count

    5
  • Joined

  • Last visited

About Quenton6

  • Rank
    Observer (3-9 posts)

Previous Fields

  • Car Model and Year
    1999 DeVille
  • Engine
    Northstar 4.6L V8 (LD8/L37)
  1. I see that this reply is a little late but maybe if someone else has this problem. I had this exact problem before and it turned out that it was my spark plug wires. I just bought a complete new set, popped them on and the problem never arose again.
  2. Well, I figured it out. The parking brake definitely was holding. When I took it for the first test drive and it was decelerating, that was the brake holding. So the wheel heated up at this point. Then when I started playing with the pedal for the parking brake it snapped or broke or something. But when I got it home I thought it was still holding because it was still hot. But turns out it was just the residual heat, they hold that heat for quite some time. So I took it for another spin and all 4 wheel are ice cold. So It kind of worked it self out. Thanks for all the replies and help.
  3. That makes sense. Actually after closer inspection. My parking brake is not clicking anymore when i push it down. It just kind of slides down and you can pull it right back up. Do you think that something slapped or broke? As soon as I get a second to jack the car back up I'll have a look under there. Oh and yes, I cleaned and lubes the hardware, didn't buy new. Cleaned the gunk and stuff off all the hardware and there was no rust on the sliders. On a side note, on the rear caliper pistons I heard that they should be lined up to match some mark on the brake pads? I didn't notice anything? Thanks for your help
  4. I recently redid all my brakes. I replaced all 4 rotors, all the pads. It wasn't too difficult and I want to say that I did everything correctly. But! I took the care for a test drive and everytime I let off the accelerator the car would decelerate significantly. I did a few hard stops. Might have helped a little, not sure. I put the parking brake on and off a few times. I think that made it a bit better as the car would coast a ways without slowing down as much. I drove it around a bit longer and then parked it at home, and my neighbor in the driveway getting her mail could smell/ feel the heat coming from my car as i drove in. So I got out and sure enough both back wheels were super hot. The fronts were practically ice cold. Please help! What could be my problem? Calipers? Parking Brake? I would like to have some experienced input before I proceed. Thanks
  5. I saw on the homepage all the mods that can be done for horsepower. K and N filters and air box mods and mufflers and etc. I was just wondering if any of these can go for the 99 Deville and which ones specifically would give more MPGs than Hp? Thanks!